VSJ – November 2007 – Sounding Board

Robin Jones tries to evoke your sympathy and makes a new case for the Very Thin Client.

One morning, a month or so ago, I turned on my workhorse computer to find that it had turned itself into an expensive automatic switch. I switched it on, it deliberated for a few minutes and then switched itself off. Or perhaps it was just making a comment about global warming. In any event, I had deadlines to meet and no time to tinker with it. A golden opportunity, I thought, to port everything on to a brand spanking new Lenovo Core2 Duo laptop and worry about the tired old tower at my leisure. Especially as my backups – well, data anyway – were bang up-to-date.

By half past eleven, Windows had downloaded the regulation 58 updates, demanding reboots, it seemed, for almost all of them individually. Virus checking was in place and Windows had been coaxed, sulking, into turning its firewall off in favour of my preferred proprietary brand. I installed Thunderbird and Firefox and ported my Thunderbird profile from the backup. Now, if I’d been thinking, I’d have downloaded Thunderbird 2. But I didn’t. I ‘saved time’ by using version 1.5 that I had on a USB memory stick. It’ll update itself automatically anyway, I thought. Yes, it did. While I was overwriting the default profile. Presumably this did unspeakable things to the registry because it suddenly became very unstable.

OK. Uninstall Thunderbird and roll back the registry, losing several other things on the way. Download Thunderbird 2, reinstall it together with Firefox et al and repeat the profile port. Restore My Documents from the backup. It all works! Write a test email to myself. All my standard email footers have disappeared. Examine the folder tree. Despite having been explicitly told not to, the backup utility has introduced an extra folder at the root level, with the same name as the next one down, so it’s not immediately obvious. Consequently, Thunderbird is looking in the wrong place. Reorganize the folders. By this time it’s 3 o’clock. I decide to do a full disc-image backup to DVDs and get some lunch while I’m waiting. Lenovo’s built-in utility is clean and user-friendly but it brightly informs me that it’ll be over an hour doing the job, so I’ve plenty of time.

OK, back to work. Install my Palm Treo software. The DVD drive refuses to read the installation CD. I remember that I had the same problem when I bought the Treo but that I had managed to coax an external drive into performing the install. I dig this out and try again. This time, no joy. Go to the Palm Web site to download the drivers. Treo 680 drivers, uniquely, aren’t there. Just out of interest – or desperation – I put the CD into the drive of an old Sony Vaio laptop that I use to run Linux. It reads the CD fine. No problem then! I’ll copy the files on to a USB stick and do the install from there. The files start to copy across OK and then Linux announces smugly that I don’t have sufficient rights to copy some of them. OK. Open another session with super user rights. Same thing happens again. I make a note of the file names in question and Google them. It turns out that they are only required for installation on a Mac. Fine. I transfer the USB stick to the Lenovo and the installation goes without a hitch until I’m invited to register my device. Since it’s already registered, I skip this step. Big mistake! For the next several days, Windows keeps crashing, complaining bitterly about a file called register.exe. It’s a while before I make the connection. Uninstall, roll back – you know the drill.

This time I register the Treo. The Palm database doesn’t turn a hair. It welcomes me as though I’m a completely new customer. Has it really created another me? I don’t know. I’ll tell you when I start receiving duplicate marketing junk. Anyway, the error messages have gone away.

Time to install a printer. At least that’ll be straightforward. Download the driver and run it. No problem. Do a test print from a pdf. Acrobat crashes. OpenOffice doesn’t crash when I try a test print but it complains there is no default printer and then, when this dialogue is dismissed, shows another one identifying the default printer correctly. Control Panel assures me the printer is installed but, even though it’s the only one there, it hasn’t set it as the default and refuses to let me do so. I explain all this in an email to Technical Support. Never write two sentences in a tech support email. They’ll respond to the easy one. Sure enough I get a response that tells me the reason Acrobat is crashing is because the printer isn’t set as default. It then explains in words of one syllable how to set the default printer. This despite my having entered ‘high’ where the report form asked for my level of experience..

I still haven’t solved the printer problem, not that I’ve tried very hard. I simply plugged in a different printer that installed without any fuss whatever. But I did find out what was wrong with the tower computer. Nothing. Well, nothing inside the computer. It turned out to be a faulty USB hub, which I discovered by accident when using it elsewhere.

Now if the above looks like a kaleidoscopic rant designed merely to make me feel better, well, you got me bang to rights, Guv. But that’s not its sole purpose. My guess is that pretty much everyone reading this has a similar story. And we’re the ones who can honestly write that we have ‘high’ experience. But what I’ve described could just as easily happen to beginners or people who don’t see themselves as on an experience ladder at all. They just want to use their damned computers. And, as things stand, they’re in everyday danger of losing years of valuable data that might cost considerably more to recover than their machines are worth. And that’s even if they’ve backed up properly, which isn’t generally made easy for them. A solution, it seems to me, is one I suggested in July’s VSJ for a different, but allied, problem. Leave all the gory processing – and the data – at the centre and access them via the Web using very thin clients. In one of those coincidences that really oughtn’t to happen, two days after I was fully running again, Michael Robertson, who brought us SIPphone, MP3Tunes and Linspire, announced ajaxWindows (http://ajaxwindows.com), which runs an entire virtual OS via just a browser (ideally Firefox 2+). This kind of Web-based service-oriented philosophy looks more and more like the way ahead, at least for the non-technical user.

[Something you’d like to get off your chest? Email me (Robin Jones) at eo@iap.org.uk.]

Comments are closed.